Total Pageviews

Thursday, 22 March 2018

Vulhub

Docker-Compose file for vulnerability environment

Vulhub - Some Docker-Compose files for vulnerabilities environment

Vulhub是一个面向大众的开源漏洞靶场,无需docker知识,简单执行两条命令即可编译、运行一个完整的漏洞靶场镜像。
在ubuntu16.04下安装docker/docker-compose:

Installation

# 安装pip
curl -s https://bootstrap.pypa.io/get-pip.py | python3

# 安装最新版docker
curl -s https://get.docker.com/ | sh

# 启动docker服务
service docker start

# 安装compose
pip install docker-compose 
其他操作系统安装docker和docker-compose可能会有些许不同,请阅读Docker文档进行安装。

Usage

# 拉取项目
git clone https://github.com/vulhub/vulhub.git
cd vulhub

# 进入某一个漏洞/环境的目录
cd flask/ssti

# 自动化编译环境
docker-compose build

# 启动整个环境
docker-compose up -d
每个环境目录下都有相应的说明文件,请阅读该文件,进行漏洞/环境测试。
测试完成后,删除整个环境
docker-compose down
本项目每个漏洞环境均附带文档,建议你购买1G内存的vps搭建漏洞测试环境,文档中所说的your-ip均指你的vps的ip地址,如果你是用虚拟机搭建测试环境,是指你的虚拟机IP,而不是docker容器内部的IP,请不要混淆。
本项目中所有环境仅用于测试,不可作为生产环境使用!

Notice

注意事项:
  1. Vulhub可能不支持在Windows下使用
  2. 为防止出现权限错误,最好使用root用户执行docker和docker-compose命令

Contribution

如果你在编译的时候出现错误,不要盲目开issue,请阅读这篇文档,希望可以对你有所帮助。

致谢列表:Contributors List

from  https://github.com/vulhub/vulhub

No comments:

Post a Comment

Note: only a member of this blog may post a comment.